一个分享个人学习、开发经验的Blog,http://www.joyphper.net

如何让php支持支持sqlite数据库

posted @ 2010-09-10 00:14 | 阅读:5086 | 评论:0 | 分类: PHP

 今天下了一个kingcms系统,很意外的发现它是支持sqllite数据库的,于是自己就想试一下,才发现自己所安装的环境不支持sqlite,去网站找了些资料,下面是我个人的总结

1、打开php.ini文件,找到

#extension=php_pdo.dll
#extension=php_pdo_sqlite.dll
#extension=php_sqlite.dll

把前面的#去掉

2、到php5目录下的ext里找到php_pdo.dll、php_pdo_sqlite.dll、php_sqlite.dll三个文件复制到windows/system32(这个目录不是确定在,要看你的环境变量的设置了,我习惯性的是放到system32下面,这样不在去设置环境变量,也不会出现一些安全问题)

3、重启apache。。。。

轻松搞定~~~

TAG: sqlite , php

共有0条评论 发表评论>>

点击换一张验证码