一个分享个人学习、开发经验的Blog,http://www.joyphper.net

Eclipse is running in a JRE, but a JDK is required

posted @ 2013-05-28 09:19 | 阅读:2429 | 评论:1 | 分类: Java

这问题现在的解决方案有两个:
1、在eclipse.ini中添加VM启动参数,制定eclipse启动使用的vm,修改后的文件内容如下
-showsplash
org.eclipse.platform
--launcher.XXMaxPermSize
256M
-vm
C:Program FilesJavajdk1.5.0_12injavaw.exe
-vmargs
-Dosgi.requiredJavaVersion=1.5
-Xms40m
-Xmx512m
顺序一定要对
2、创建一快捷方式,起始目标为:"D:***eclipse.exe" -vm "C:***Javajdk1.6.0_03injavaw.exe".
其实我感觉在ini文件中写绝对路径不是一种很好的方式,但是使用相对路径和环境变量%JAVA_HOME%却会找不到jdk,一旦我将eclipse移动到别的地方,这段ini还必须要重新配置下。

TAG: java , eclipse

共有1条评论 发表评论>>

Makalah 发表于:2016-05-18 21:23
Det har ikke jeg fått med meg. Så kult! (Ps! finner du deg selv i en siutjsaon hvor du har henda fulle av boxere så kan jeg gjerne trenge noen nye!) lykke til!
点击换一张验证码